Hotmail��͌���

1999�N10��30�� �Ƃ悵��

�T�e

hotmail��web�ȊO���痘�p������A����ȕ��@��p���鎖�Ō����I�Ƀ��[���f�[�^�ɃA�N�Z�X�ł���B�{�e��hotmail��POP3�Ή��̒��̃��[���[����ǂނ��߂ɊJ���\���POP3 to Web-Mail Gateway�J���̂��߂�����ꂽ�B�܂��A���̎�����������ɂ�����AOutlook Express�̒�M���e���Q�l�ɂ����B


�v���g�R��

hotmail�Ŏg�p�����v���g�R����AHTTP/1.1���x�[�X��A�኱�Ǝ��g�����{�������̂ł���B�܂��A�F�؂ɂ�Digest�F�؂�p����̂�A����ɑΉ����Ă��Ȃ���΂Ȃ�Ȃ��B�Ǝ��g���͎��A���N�G�X�g�R�}���h�̒lj���A���X�|���X�X�e�[�^�X�̒lj��ł���B�����ɂ‚��Ă͎�������������BDigest�F�؂ɂ‚��Ă�rfc-2617���Q�l�̎��B�܂��A�{��Digest�F�؂�HTTP/1.1�̌��Ɏ��������ׂ��ł��邪�AHTTP/1.0��Ɏ������Ă�hotmail�𗘗p����ɂ������Ė��͊m�F����Ă��Ȃ��B�܂��AUser-Agent��Outlook Express����K�v������A�Ƃ������Ƃɒ��ӂ��Ȃ���΂Ȃ�Ȃ��B

 

�lj����ꂽ���N�G�X�g�R�}���h

�R�}���h

���

PROPFIND

Login���̃��[�U�[�ɑ�����A�e��f�[�^�ɃA�N�Z�X���邽�߂�URL�ƕt�����������B�ǂ̃f�[�^�Ɋւ��Ē������邩��content�Ƃ��đ��M�����XML�ɋL�q�����B���̃R�}���h�͕����̗v���𓯎��ɔ��s���邱�Ƃ��ł���悤�ɂȂ��Ă���B

PROPPATCH

Login���̃��[�U�[�ɑ�����e�f�[�^�ŗL������X����B��Ƀ��[���̖��ǃt���O�̕�X���ɗ��p�����B

MOVE

�K�w������Ă���e�f�[�^��ʊK�w�Ɉړ�����B��Ƀ��[�������ݔ��ֈړ������铙�ɗ��p�����B

 

�lj����ꂽ���X�|���X�X�e�[�^�X

�R�[�h

���

207 Multi-Status

PROPFIND�ɑ΂��鉞���Ƃ��ĕԂ��B�v�����Ƃ̃��X�|���X�ƃX�e�[�^�X��v�������񋓂������̂�XML�Ƃ��ĕԓ����Ă���B

 


�T�[�o�[�ւ̃A�N�Z�X

hotmail�ւ̓�����ƂȂ�URL��http://services.msn.com/svcs/hotmail/httpmail.asp �ƂȂ��Ă���B�������A��킱�̃A�h���X��301/302����Ԃ��Ă���̂�ALocation��]����ēx�ʃT�[�o�[�ɃA�N�Z�X���邱�ƂɂȂ�͂��ł���B�ړ���̃A�h���X���ɕ�X�����”\�������邽��A�A�N�Z�X���ɂ͕K�����̃A�h���X���璲�ׂ�ׂ��ł���B

 

���O�C��

���O�C�����J�n���邽�߂ɂ��Ŏ�����URL��PROPFIND��M����K�v������B�������A�h���X�ɃA�N�Z�X�����A401��Ԃ��Ă���B����ۗv�������F�؂�Digest�F�؂ƂȂ��Ă���B�N���C�A���g�̓��[�U�[���A�p�X���[�h��]��Digest���v�Z���A�������܂�A�ēx�T�[�o�[��PROPFIND�Ƃ��đ���B���̃��X�|���X�Ƃ���207���Ԃ��ė����Ȃ��O�C��������ł���BPROPFIND�Ƃ��đ���f�[�^�͎擾����������XML�ŗ񋓂������̂ł���B���ɑ�\�I�ȑ��M���e�̗�������B

 

<?xml version="1.0"?>

<D:propfind xmlns:D="DAV:" xmlns:h="http://schemas.microsoft.com/hotmail/" xmlns:hm="urn:schemas:httpmail:">

     <D:prop>

         <h:adbar/>

         <hm:contacts/>

         <hm:inbox/>

         <hm:outbox/>

         <hm:sendmsg/>

         <hm:sentitems/>

         <hm:deleteditems/>

         <hm:drafts/>

         <hm:msgfolderroot/>

         <h:sig/>

     </D:prop>

</D:propfind>

 

D:prop�̓����ɂ���̂��v��������̗񋓂ƂȂ��Ă���B���X�|���X�͈ȉ��̒ʂ�B

 

<?xml version="1.0" encoding="windows-1252"?>

<D:multistatus xmlns:D="DAV:" xmlns:m="urn:schemas:mailheader:" xmlns:hm="urn:schemas:httpmail:" xmlns:c="urn:schemas:contacts:" xmlns:h="http://schemas.microsoft.com/hotmail/">

     <D:response>

         <D:href>http://�c/</D:href>

         <D:propstat>

              <D:prop>

                   <hm:contacts>http://�c/abdata/</hm:contacts>

                   <hm:inbox>http://�c/folders/ACTIVE/</hm:inbox>

                   <hm:sendmsg>http://�c/sendmsg/</hm:sendmsg>

                   <hm:sentitems>http://�c/folders/sAVeD/</hm:sentitems>

                   <hm:deleteditems>http://�c/folders/trAsH/</hm:deleteditems>

                   <hm:msgfolderroot>http://�c/folders/</hm:msgfolderroot>

                   <h:sig>______________________________________________________

Get Your Private, Free Email at http://www.hotmail.com

</h:sig>

              </D:prop>

              <D:status>HTTP/1.1 200 OK</D:status>

         </D:propstat>

     </D:response>

</D:multistatus>

 

�v���ɑΉ�����URL���������Ă���B�ȉ��̑���͂����œ����eURL�ɑ΂���PROPFIND��M���邱�Ƃ�s���B�܂��A���O�C�����ɂ̓��N�G�X�g�w�b�_��uDepth: 0�v��uBrief: t�v��t�����Ă����K�v������B

 

�t�H���_���̖₢���킹

���O�C�����ɓ���URL�ɑ΂���PROPFIND��M���邱�ƂŔC�ӂ̊K�w�̃f�[�^�����o����B

���N�G�X�g�̗�͎��̒ʂ�B

 

<?xml version="1.0"?>

<D:propfind xmlns:D="DAV:" xmlns:hm="urn:schemas:httpmail:" xmlns:m="urn:schemas:mailheader:">

     <D:prop>

         <D:isfolder/>

         <hm:read/>

         <m:hasattachment/>

         <m:to/>

         <m:from/>

         <m:subject/>

         <m:date/>

         <D:getcontentlength/>

     </D:prop>

</D:propfind>

 

���X�|���X�̗�͎��̒ʂ�B

 

<?xml version="1.0" encoding="windows-1252"?>

<D:multistatus xmlns:D="DAV:" xmlns:m="urn:schemas:mailheader:" xmlns:hm="urn:schemas:httpmail:" xmlns:c="urn:schemas:contacts:" xmlns:h="http://schemas.microsoft.com/hotmail/">

     <D:response>

         <D:href>http://�c/folders/ACTIVE/MSGxxxxxxxxx</D:href>

         <D:propstat>

              <D:prop>

                   <hm:read>0</hm:read>

                   <m:to></m:to>

                   <m:from>=?iso-2022-jp?B?SG90bWFpbCAbJEIlQSE8JWAwbEYxGyhC?=</m:from>

                   <m:subject>=?iso-2022-jp?B?SG90bWFpbCAbJEIkWCRoJCYkMyQ9GyhCIQ==?=</m:subject>

                   <m:date>1999-10-30T03:14:25</m:date>

                   <D:getcontentlength>233</D:getcontentlength>

              </D:prop>

              <D:status>HTTP/1.1 200 OK</D:status>

         </D:propstat>

     </D:response>

</D:multistatus>

 

���̒�M��Ainbox�ɂ͂P�‚̃��[��������������A���̃��[���w�b�_��񂪂��Ƃ�Ƃ���Ă���B�������[����������ɂ�AD:response�������񋓂���鎖�ɂȂ�B�܂��A�t�H���_���擾���ɂ̓w�b�_��uBrief: t�v��uDepth: 1,noroot�v��t����K�v������B

 

���[���̓ǂ�o��

��L�̎��Ńt�H���_������擾���邱�Ƃ�A�e���[�������o�����߂�URL�ihttp://�c/folders/ACTIVE/MSGxxxxxxxxx�j��������B���̃A�h���X�ɑ΂���GET�R�}���h�𑗂鎖�Ń��[������M�ł���B�܂��A����URL�̓��j�[�N�ɂȂ��Ă���̂�A���̂܂�UIDL�Ƃ��Ďg�p�ł���B����GET�̃��N�G�X�g�̗�������BGET�ɂ̓R���e���g�͂Ȃ��̂Ńw�b�_���f�ڂ���B�����PROPFIND�����s���Ƃ������l�ł���A���킹�ăT���v���Ƃ���B

 

GET /cgi-bin/hmdata/folders/ACTIVE/MSGxxxxxxxxx HTTP/1.1

Accept: message/rfc822, */*

Translate: f

User-Agent: Outlook Express/5.0 (MSIE 5.0; Windows 98; DigExt)

Proxy-Connection: Keep-Alive

Pragma: no-cache

Authorization: Digest username="[email protected]", realm="hotmail.com", qop="auth", algorithm="MD5", uri="/cgi-bin/hmdata/folders/ACTIVE/MSGxxxxxxxxx", nonce="OTQxMjUzMzcxOjcyNDZiMTVlOTFiOGFlZTUyNGE0ODRkZDBlNmNjNzdl", nc=00000004, cnonce="833a03c26c473879455249498ee51dbe", response="7d2cf965ea54b028ffb6a076e16c3287"

 

 

���̃��N�G�X�g�ɑ΂��郌�X�|���X�̗�͎��̒ʂ�B

 

HTTP/1.1 200 OK

Date: Sat, 30 Oct 1999 03:16:53 GMT

Server: Apache/1.3.6 (Unix) mod_ssl/2.2.8 SSLeay/0.9.0b

Cache-Control: no-cache

Expires: Mon, 01 Jan 1999 00:00:00 GMT

Pragma: no-cache

Connection: close

Content-Type: message/rfc822

 

From: =?iso-2022-jp?B?SG90bWFpbCAbJEIlQSE8JWAwbEYxGyhC?=

Subject: =?iso-2022-jp?B?SG90bWFpbCAbJEIkWCRoJCYkMyQ9GyhCIQ==?=

Date: Sat, 30 Oct 1999 03:14:25 +0000

Mime-Version: 1.0

Content-Type: text/plain; charset=iso-2022-jp

 

$B?7$7$$%f!<%6!<$N3'MM$X(J

 

MSN Hotmail $B$X$h$&$3$=!#(JMSN Hotmail $B$O!"%$%s%?!<%M%C%H$G:G$b5^[email protected]$7$F$$$k%3%_%e%K%F%#$G$9!#(J

 

$B%F%-%9%HI=<($N%V%i%&%6$G$O!"(JMSN Hotmail $B$N0lIt$N5!G=$,MxMQ$G$-$^$;$s!#(JMSN Hotmail $B$r;H$&$H!"$[$+$N(J Web $B%Z!<%8$X$N%j%s%/$d2hA|$J$I!"K-IY$JFbMF$r4^$`EE;R%a!<%k$r$d$j$H$j$9$k$3$H$,$G$-$^$9!#(J 

 

$B$<$R!"2hA|$KBP1~$7$?%V%i%&%6$G(J MSN Hotmail $B$r$*3Z$7$_$/$@$5$$!#(J

MSN Hotmail $B%9%?%C%U(J

 

 

���[�������ǂɂ���

���󂯂��΂���̃��[���͖����ԂɂȂ��Ă���B����������Ԃɂ��邽�߂ɂ̓��b�Z�[�W�ɑΉ�����URL�ɑ΂���APROPPATCH�R�}���h��M����K�v������B���̎��w�b�_�ɂ�uBrief: t�v���K�v�ł��邱�Ƃɒ��ӂ���B�������ɂ�200���Ԃ�B

 

<?xml version="1.0"?>

<D:propertyupdate xmlns:D="DAV:" xmlns:hm="urn:schemas:httpmail:">

     <D:set>

         <D:prop>

              <hm:read>1</hm:read>

         </D:prop>

     </D:set>

</D:propertyupdate>

 

���[�������ݔ��ֈړ�����

�ǂ�I��������[�������ݔ��ֈړ����邽�߂ɂ�A���b�Z�[�W�ɑΉ�����URL�ɑ΂���AMOVE�R�}���h��M����K�v������B���̎��A�t�H���_���̖₢���킹���ɕԂ��Ă������ݔ��̃A�h���X���K�v�ɂȂ�B�ȉ��AMOVE�R�}���h��A����ȕ������グ�ĉ������B

 

MOVE /�c/folders/ACTIVE/MSGxxxxxxxxx HTTP/1.1

Destination: http://�c/folders/trAsH/MSGxxxxxxxxx

Allow-Rename: t

Content-Length: 0

.

.

.

 

Destination�ɂ͈ړ���ł�URL���w�肷��K�v������B����URL�̓t�H���_���̖₢���킹���ʂƂ��ē���ꂽ���̂�A���b�Z�[�W�̖��O�iMSGxxxxxxxxx�j�����������̂ł���B�܂��A�uAllow-Rename�v��ut�v���w�肵�Ă�����A�ړ���̖��O���Փ˂��Ă��Ă��A�����I��œK�Ȗ��O�ɕ�X���Ă������̂Ǝv����i���m�F�j�B���X�|���X�Ƃ��Ă͈ȉ��̂悤�Ȃ��̂��Ԃ��Ă���B

 

HTTP/1.1 201 Created

Date: Sat, 30 Oct 1999 03:17:16 GMT

Server: Apache/1.3.6 (Unix) mod_ssl/2.2.8 SSLeay/0.9.0b

Cache-Control: no-cache

Expires: Mon, 01 Jan 1999 00:00:00 GMT

Pragma: no-cache

Location: http://�c/folders/trAsH/MSGxxxxxxxxx

Connection: close

Content-Type: text/html; charset=shift_jis

 

<!-- IP: xxx.xxx.xxx.xxx -->

<!-- V: 08.05.10.0008 -->

<!-- D: Thu Oct 14 16:00:25 PDT 1999 -->

 

�X�e�[�^�X��201��ALocation�Ɉړ����URL�������Ă��邱�Ƃɒ��ӂ���B


�Q�l

RFC1945 -- Hypertext Transfer Protocol – HTTP/1.0

RFC2616 -- Hypertext Transfer Protocol – HTTP/1.1

RFC1321 -- The MD5 Message-Digest Algorithm

RFC2617 -- HTTP authentication: Basic and Digest Access Authentication